API returns no works for a DOI that does resolve

Hi - I am seeing a few cases where I do an API works query that returns no results for a DOI that does resolve to a URL.

I tried to post the actual URLs but it is not allowing any links in the post.

DOIs pattern are: 10.1353/sub.0.0003, 10.1353/ajh.2006.0019

This is an extremely rare occurrence (50 out of 100,000+) but I want to make sure I am not doing something wrong. Is there something going on here that I am not accounting for?

Thank you,


Hi @ajt_muse ,

Thanks for flagging these for us.

I see both of those example DOIs in our APIs:

DOI 10.1353/sub.0.0003
REST API: https://0-api-crossref-org.pugwash.lib.warwick.ac.uk/works/10.1353/sub.0.0003?mailto=support@crossref.org
XML API: https://0-doi-crossref-org.pugwash.lib.warwick.ac.uk/search/doi?pid=support@crossref.org&format=unixsd&doi=10.1353/sub.0.0003

DOI 10.1353/ajh.2006.0019
XML API: https://0-doi-crossref-org.pugwash.lib.warwick.ac.uk/search/doi?pid=support@crossref.org&format=unixsd&doi=10.1353/ajh.2006.0019
REST API: This DOI has been aliased to another DOI. Because of that, we have hidden it from being retrieved. We’re working on a better way of communicating this via the REST API response for aliased DOIs, but that’s the reason you’re receiving a ‘resource not found’ message for this DOI in the REST API.

The result in the XML API confirms that the DOI has indeed been aliased to its primary DOI:

Please let me know if you have any additional questions,

Thanks Isaac.

I was assuming it was because of an Alias situation.

I am going to switch my process to use the XML query instead of the REST API.



1 Like

Hi Abba,

I agree with that switch. Also, I updated your account in the forum so you can post links going forward.


Another example, seemingly of the same nature as those in the opening post.

The url corresponsing to this DOI yields a redirect as expected - 10.22059/jcamech.2022.348203.754

However, the works API returns “Resource not found.”

(I tried hard to avoid links in the message, since I am not allowed to include them.)

Hi Alexander,

10.22059/jcamech.2022.348203.754 is a different situation. That DOI was registered with a different registration agency, mEDRA.

There are several DOI registration agencies. The majority of DOIs for scholarly publications are registered with Crossref, but definitely not all.

Only Crossref DOIs are indexed in our APIs and searchable on our Metadata Search interface. So, that’s why you can’t find a record for 10.22059/jcamech.2022.348203.754

You can check the registration agency for a DOI using the following API route:

Checking 10.22059/jcamech.2022.348203.754 that gives you

which returns the response

"message": {
"DOI": "10.22059/jcamech.2022.348203.754",
"agency": {
"id": "medra",
"label": "mEDRA"

mEDRA maintains their own API with documentation here

And, mEDRA, DataCite, and Crossref collaborate in supporting the Content Negotiation service which will give you basic bibliographic metadata for DOIs from all three agencies. That’s documented here

I hope that helps clarify things.

And, sorry about the restriction on putting links in your posts. It’s necessary to help avoid spam on the forum.