Blank pages on Administrator menu (unable to register DOI)

We registered articles via the Web Deposit (CrossRef - DOI Deposit Form ) but did not received any confirmation that the process was successful. Unfortunately, the Technical Contact reported that the pages on his account after logging in are blank:

As I understand, this is why the process of registration DOI was not finished (the blank page appears after logging in at the end of the process). What is the problem here? Should someone else log in at the end? Why technical contact cannot upload DOIs?
Thanks for your attention. I’m looking forward to your reply.

1 Like

Hello @jlepicka ,

Thanks for your message, and welcome to the community forum! You’re not the first person to report a problem with this login. It could be related to the credentials you are using, but I’d need more details about your account and the username and/or email address being used in the registration. If you can send me details about your account to, I’ll gladly take a closer look.

For our other members who have reported this problem, we found that updating to a new version of their browser and/or checking on firewall settings on their end did the trick. Let’s start with the additional account details that I have requested above and we can go from there.

Looking forward to the additional details,

Hello Isaac,

Thank you - we checked our browsers and firewall settings - unfortunately, the problem is still there. I sent you the login/email details in private message and to I think there is something wrong with credentials and I have no idea how to fix it.
Kind regards,

Hi Isaac,

When exactly can I expect fixing the problem with credentials? I guess there is nothing more I can do now.

Hi Joanna,

I thought one of my colleagues picked up your request into and provided you with a response. I’m checking on that now.


Thank you Isaac,
so far noone reached out to me or to Technical contact. This case is crucial for us and I really hope to get it fixed as soon as possible.


Hi @jlepicka , I don’t see a message from you into, but I do see one from your colleague, Zuzanna. Sally on our membership team responded to Zuzanna with this on Friday, 10 September:

Thank you for your message. We note that your account’s Technical contact has received login credentials for use in depositing DOIs with Crossref. We’re confused by your reference to ‘downloading’ DOIs - you need to generate full DOIs based on the DOI prefix we’ve assigned to your account (10.53301), then register these with Crossref.

May I suggest that you check out the following online resources initially?

  • Our content registration guide provides a useful overview of the content registration process.
  • You can find out how to choose the most appropriate content registration mechanism for your organization here.
  • You can access a recorded webinar on getting started with content registration here.

If you then require further guidance, please don’t hesitate to contact our Support Team ( for help.

If you would like us to issue login credentials to others at your organization, just provide me with their name and email address and I can set up additional user credentials for them.

Take a look and let me know how else we can help!


Hi Isaac,
This is not the case we are talking about. As you can see from the message, Zuzanna tried to get some help, but she don’t know the process as well as I do.

As you write, ‘We note that your account’s Technical contact has received login credentials for use in depositing DOIs with Crossref’ - well, we know this. I screenshoted the issue at the beginning, didn’t I? The credentials are not working and we are unable to register DOI. Unfortunately, noone answered our concerns about the blank pages screenshoted above.

I wrote another e-mail to now.

Hi @jlepicka,

We cannot replicate the issues you are reporting with the web deposit form. Are you receiving the blank page after entering your metadata into this form:

Or, are you getting that simply when you visit this URL: CrossRef - DOI Deposit Form

Can you visit this address - What browser do I have? | - and let me know the details of your browser?

I see that @pdavis is helping you via We’ll be discussing this together shortly. I hope we can get this sorted as soon as possible.



We are receiving empty pages on Administrator menu simply after logging in ( ). There is no way we can see any menu or list of submissions – as you can see on the screenshots.

There is simply no menu or anything we can click on when our Technical contact logs in (login: ).

To finalize process of adding articles via Web Deposit Form, you have to log in.

We did it and there was nothing to click on and we did not received any information of successful submission.

The browser details:

  • Browser Chrome 93.0.4577.63

  • Engine WebKit 537.36

  • OS Windows 10

  • User Agent
    Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/93.0.4577.63 Safari/537.36


  • Browser Firefox 92.0

  • Engine Gecko 92.0

  • OS Windows 10

  • User Agent
    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0

Kind regards,


Yes, that does all look good. Thanks for providing the information on the browsers. I use the same versions, so that’s not the issue. Glad we can eliminate that.

We have only seen this error a small number of times before and in most cases it has been fixed by changing browsers or firewall settings on the PC. Sometimes there has also been a need to access the web pages on a different network, so we would ask you to check accessing the web page from a computer off of the network and even a personal one to check everything in that environment.

Paul and I have checked and we are able to alias in as your account and so it is more likely and issue with the client setup or network. Has anyone been able to login to the admin system correctly?

Have you tried different PCs in different locations?

Thanks for your patience with this, I hope we can help you get going very soon.


I tried my personal computer from home and there is still nothing on Grzegorz account.
What is more - our firm works for another journal with DOI and we can operate on this account (everything works just fine for the other journal!). Of course this won’t fix the problem we are talking about, but at least I am sure that there is something wrong specifically with our Technical contact account.

Can you help me register DOIs some other way? I need them as soon as possible, as I mentioned our journal is waiting with printing the newest issue.

And to be clear, noone been able to login to the admin system correctly, I cleared all of the cache from the browser, tried different browsers and different PCs.
And we paid the fee for Crossref of course.

Please let me know how can we get DOIs as soon as possible? I see nothing has changed on our Technical contact account.

I really need to register DOIs for the newest issue as soon as possible.

Can you register a small number of articles with provided data from me and work on this bug separately?

I am asking about this specifically because our agents did everything correctly and this bug is entirely on your side.

I see you gave me credentials to handle the submission for the journal, thank you! I logged in and I can see the Admin panel et al. Thank you and I am going to register DOI now - I hope it’s working :slight_smile:

So happy to hear that Paul was able to get you access so you can make your submissions. Thanks for your patience, Joanna. These types of errors are difficult to troubleshoot, so I appreciate you bearing with us.

I’m going to continue to dig to see what might have been the issue with the other email address/credentials (I may need to get our technical team involved as we haven’t seen this as the cause of the problem in the past). I’ll follow up via the support desk ticket when I have more about the underlying cause.